This project has moved. For the latest updates, please go here.

API key

Apr 17, 2015 at 2:30 PM
Hi everybody,
I installed MapChart3.0 on CRM2015 online. Unfortunatelly I cann't pass the line
"in the command bar click on Set API Key"
Where is it?
I go into entity and ...
artrosis.pl/sites/all/themes/bluemasters/images/crm.png

regards, Jacek
Apr 17, 2015 at 2:39 PM
One more. Mayby it's possible to hard code?
Coordinator
Apr 17, 2015 at 6:10 PM
That's not the right place.

This is what you need:
Image
Apr 17, 2015 at 8:09 PM
Thx for quick answer but ...
Image
I can not see it :(
Apr 17, 2015 at 8:14 PM
Image

after deselecting map
Coordinator
Apr 17, 2015 at 9:31 PM
Edited Apr 17, 2015 at 9:38 PM
Interesting. It should also show up in the form ribbon if you open any of those maps, so try looking there.

Also, have you done a Publish All, since you've imported the solution?
Apr 18, 2015 at 6:32 AM
Yes, I published all. Today I even removed ChartMap and imported again. Strange thing is yesterday I had not default entities (Account locations ect) - after today import it's there. Anyway there is no APIkey :( So, is it possible to rebuild ribbon somehow manually?
Apr 20, 2015 at 2:41 PM
One more. Is it possible to start method for entering key manualy from debugger? I think it's SetBingMapsKey().
Coordinator
Apr 20, 2015 at 11:32 PM
JacekStupkiewicz wrote:
One more. Is it possible to start method for entering key manualy from debugger? I think it's SetBingMapsKey().
Yes, if you're comfortable doing that, then it's fine. All that function does is update the "BingMapsApiKey" attribute on your organization entity. You don't even have to do it in javascript, you can use any method you like.
In CRM Onpremise, there is the ability to set that value in the System Settings. But in CRM Online that setting is not exposed, that's why I added that button. The button is supposed to automatically detect if you are using CRM Online, or CRM onprem, and only be displayed if you are using Online.

I would still like to find out why that button isn't being displayed for you... Your URL is "yourorgname.crm.dynamics.com", correct?
Apr 21, 2015 at 8:45 AM
Edited Apr 21, 2015 at 9:38 AM
Oki. I work around it :).