Heat Maps not showing anything.

May 7, 2015 at 7:33 PM
I installed CRM Chart Map 3.0 RC1 on a CRM 2013 site. The Pin maps work. But the Heat Maps don't showing anything on the map. Any thoughts?
Coordinator
May 11, 2015 at 6:07 PM
The OOB heat map requires data in the estimated value field, and the parent customer field, and the parent customer must be an account.
Of course, you can modify all of those settings as needed.
May 12, 2015 at 4:26 PM
I'm a little confused. There is no OOB Heat Map. I had to create them myself. I created one for the Account entity. So, are you saying my accounts need Parent Accounts?

I also looked in both the Contact, Account, and Chartmap entities, and there is no "Estimated Value" field. So I'm not sure what you are talking about regarding that field Wedge.

Thanks.

JC
Coordinator
May 14, 2015 at 4:45 AM
After you install the solution, and publish for the first time, it will automatically generate 4 maps for you, one for Account, Contact, Lead and Opportunity. The first 3 are standard pin maps, the Opportunity map is a Heat Map, that's the one I was referring to. If your talking about a custom heat map on Account, then ignore what I said.

Can you post a screenshot of your heatmap settings?
May 18, 2015 at 11:47 AM
This site doesn't appear to allow uploading of screenshots...
Jun 1, 2015 at 11:38 AM
Hi Wedge905,

I am also having trouble creating a custom heat map for contacts or accounts.

Image

i'm trying to the heat map to show number of contacts in an area. not sure if its set up wrong or its just not working.

Also when i tried to emulate the opportunity heat-map using parentcustomerid.address1_line1 for contact i get a business process error. Also tried using just parentcustomerid but they all appear blank
Coordinator
Jun 5, 2015 at 5:30 PM
Edited Jun 5, 2015 at 5:32 PM
The parentcustomerid.x just allows you to use the address details from a parent record. You don't need that if you're mapping on the Contact entity.
The settings in that screenshot looks pretty good.

I notice you're using en-GB, but still have the default lat/long on North America. Bing Maps has a feature, that when an address is searched, it mostly searches within the current visible area of the map. So, if most of your addresses are somewhere in GB, you might get better results if you change the default location and zoom to display GB.

A few other troubleshooting things you can try:
Try turning on Location Caching
Try turning off Location Caching AND removing the values for Latitude Field and Longitude Field
Also, try turning on the Dynamic Radius setting

Edit: AND of course, always do a Publish ALL after making map changes. Otherwise they won't take effect.

If you get it working, please let us know what fixed it for you. And if it still doesn't work, let us know anyway, and we'll keep looking.
Coordinator
Jun 5, 2015 at 5:36 PM
One more thing: when you are testing it, be sure to test it on a view with only a very small number of records, like 10 - 20. Make sure that works first, then test with larger data sets.
Jun 22, 2015 at 9:33 AM
Thanks for getting back to me on this.

I have done the above suggested steps and nothing worked for the Heat map. I do have the location now changed to UK and zooms into the correct location but the heat map is not displaying on the it.

here are the settings:

https://www.dropbox.com/s/4gvlx1z1gqz4g1f/HeatMapContactSettings.PNG?dl=0


Here is the Heat map which is not showing anything:

https://www.dropbox.com/s/1qywhzkon4hljwe/HeatMapView.PNG?dl=0

Thanks,
Peter
Coordinator
Jun 23, 2015 at 5:32 PM
Those look like test contacts, right? If so can you send me the list of contacts w/addresses, that you are testing with? Also, include the fetchXml from the view that you are testing with, it looks like an OOB view, but it might not be.

I'll be able to get to the bottom of it much more quickly, if I can troubleshoot and debug for myself.
Jun 29, 2015 at 11:38 AM
Thanks the reply,

requested files are in the links below.

I have include the FetchXml for the contacts from the advanced find FetchXMLADF and the Fetch for the view which is active contacts which OOB.

Also the test data include.

ADF Fetch

https://www.dropbox.com/s/7l79n58fhakcdy9/FetchXMLADF.xml?dl=0

Active Contact Fetch

https://www.dropbox.com/s/xj9bnr7prslg9ki/FetchXML%20Active%20Contacts.xml?dl=0

Test Data

https://www.dropbox.com/s/2c0qfedlinqf9nb/For%20Re-import%20-%20Contacts%20Advanced%20Find%20View.xml?dl=0

Many thanks,
Peter
Jul 8, 2015 at 3:23 PM
Hi PeterC26/wedge905,

Im having the same issue, where you able to figure out the problem?
Feb 26, 2016 at 9:06 AM
Hi all,

I have the same problem, I am getting an error in this function: grd.addColorStop(0.0, 'rgba(0, 0, 0, ' + (_locations[i].intensity || _options.intensity) + ')'); // Use supplied value or default intensity
error is: "Syntax error"

I am using contact with the OOB view "Active contacts" on CRM 2015 on line.

Thanks
Feb 26, 2016 at 2:18 PM
FYI

I fixed it with the following code:

//grd.addColorStop(0.0, 'rgba(0, 0, 0, ' + (_locations[i].intensity || _options.intensity) + ')'); // Use supplied value or default intensity
        var intensity = _locations[i].intensity != "NaN" ? _locations[i].intensity : _options.intensity;

        grd.addColorStop(0.0, 'rgba(0, 0, 0, ' + intensity + ')');