Map displays in chart, with no actual map

Mar 1, 2015 at 3:40 PM
This product looks like exactly what I need, but after configuring the entity to work with the chart, the chart name appears on the entity, but no map shows up at all. Any tips? Using CRM 2013 hosted in azure. Here is a screenshot of the chart not displaying the map.

Image

One point here is that my table already has the GPS coordinates populated, as opposed to needing it to be decoded. I did fill in one address field just to test if that is the problem, but it still didnt work.

Even if the coordinates were the issue, I would think the map would appear with no pins.

Help would be appreciated, thank you!
Coordinator
Mar 2, 2015 at 5:30 PM
If you have the latitude and longitude fields with values already, just enter those fields when you configure the chart and it will be able to use them properly. I don't think that is the problem.

Are you able to open a debug window and capture the error message?
Mar 2, 2015 at 5:46 PM
thanks so much for the response. here is a quick video of the browser in debug. Let me know if I am focused on the wrong section - https://www.dropbox.com/s/9ad9xs5ey70ncna/map%20not%20appearing.MP4?dl=0
Coordinator
Mar 2, 2015 at 6:05 PM
That's close enough. It looks like you haven't done a Publish All, after importing the solution. Give that a try, and if it still doesn't work, try re-importing the solution and do a Publish All.
If it still doesn't work, then navigate to CRM > Settings > System Jobs, and look for any system jobs related to the chart map solution that completed with error. Any of those failed jobs will have a trace log attached to it, just paste those log(s) here.
Mar 2, 2015 at 6:41 PM
What a rookie mistake, that did the trick! One more issue. I have an enterprise bing map key which is used in my org. It works on all the forms in embedded maps, but for some reason, the chart/map created with your solution still sayd "the specified credentials are invalid, sign up for a free bing map key". is there any issue with using an enterprise key?
Coordinator
Mar 2, 2015 at 6:47 PM
The current release doesn't use the same key you have entered into CRM settings. That version was developed in 2011, before CRM had a dedicated location to store a key. So, the key is stored in a web resource instead.
Go to the solution configuration page, and enter your key there. Click Save on the page, and then you have to do a publish for the key to be applied.

Note: the upcoming 3.0 release is being developed for 2013/2015. This new release will eliminate the configuration web resource, and will use the key stored in CRM instead.
Mar 2, 2015 at 7:05 PM
alright! Thanks! Do you have any plans to offer breadcrumb functionality where based on the order of the view, the pins are numbered in ascending order based on the order of the records in the view? this way a user can view a map and see the trail? Perhaps I have a list of appointments and want to see the map pins of each appointment in order of the schedule?